Argentina - PayOuts outage

Incident Report for PayRetailers

Resolved

This incident has been resolved.
Posted Jul 07, 2025 - 17:21 UTC

Identified

We would like to inform you that we have identified an outage on PayOuts.
Our team is actively investigating the issue and working to resolve it as quickly as possible. We will closely monitor this situation and provide updates at the earliest convenience.
Posted Jul 07, 2025 - 08:43 UTC
This incident affected: Payouts.