Backoffice Issues

Incident Report for PayRetailers

Resolved

This incident has been resolved.
Posted Oct 03, 2025 - 09:00 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 01, 2025 - 22:59 UTC

Investigating

We are currently experiencing issues affecting the Merchant Portal in some cases. Our team is investigating the cause and working to restore full functionality as soon as possible.

Thank you for your patience and understanding.
Posted Oct 01, 2025 - 22:04 UTC
This incident affected: Merchant Portal.