Back Office is undergoing performance issues

Incident Report for PayRetailers

Resolved

This incident has been resolved.
Posted Oct 15, 2025 - 12:47 UTC

Investigating

We would like to inform you about an ongoing incident with our Back Office. Our team is actively investigating the issue and working to resolve it as quickly as possible.

At this time, users may experience difficulties accessing the platform or generating reports.

We will keep you updated on the progress of the resolution and notify you as soon as the issue has been fully resolved.

Thank you for your understanding.
Posted Oct 15, 2025 - 10:38 UTC
This incident affected: Merchant Portal.