PayOuts decreased on Brazil

Incident Report for PayRetailers

Resolved

This incident has been resolved.
Posted Apr 22, 2025 - 10:34 UTC

Investigating

We would like to inform you that we have identified a decrease on PayOuts.
Our team is actively investigating the issue and working to resolve it as quickly as possible. We will keep you updated on the progress of the resolution and notify you once the issue has been fully resolved.
Posted Apr 22, 2025 - 10:13 UTC
This incident affected: Payouts (Brazil).